Like

Anyone good with cars?

 

Silver Member
Username: Skdooley

Roanoke, VA Usa

Post Number: 496
Registered: Oct-09
So last night I had to take my g/f to the hospital and while going there my car started making a noise I have never heard it do before. The turn signal clicker is making a constant clicking sound, even when it isnt on. Its also going at a constant speed rather than intermidiate like when you have the clicker itself on. It however seems to stop and start when I hit a hard enough bump in the road. It seems to me maybe something is loose or either the turn signal clicker is going bad. Any thoughts? And should I be concerned? As for what was wrong with my g/f, it turns out she has a kidney infection. Some antibiotics are going to do the trick.
 

Gold Member
Username: Mrskullz1

New York

Post Number: 1535
Registered: Feb-07
Glad your gf is fine.

As far as the noise goes, I think something may have gotten loose thats causing that noise. Usually when the turn signal clicker ticks faster than usual, its because one of your lights are out. But if you hear it without the signal being on, my guess would be something got knocked loose.
I am no expert at this, just speculating. I don't think its something serious tho...
 

Gold Member
Username: Southernrebel

Monroe, Louisiana Team Audible...

Post Number: 7960
Registered: Mar-04
Its gotta be the flyback on the rectifier. I bet your powerband gave out also, I would change it to a red one. The stock blue ones seem to give out too easily.
 

Gold Member
Username: Livin_loud

MW2 Addict

Post Number: 3106
Registered: Jan-06
sounds like a loose wire.

could also be the flyback on the rectifier.
lol.
 

Platinum Member
Username: Lklives

Post Number: 16298
Registered: Jan-06
Obviously ya have an electrical problem...and they ain't easy to track most times..if it started with your turn signals, then check out the bulbs...front and rear...and look around for anything that appears loose...otherewise, go see yer local mechanic..or maybe even yer local trade/tech school, which many do free labor...

that flyback on a class 2 rectifier, made on models since 1998, have been troublesome..ask the local parts store and mechanic about that...lol

is it serious?....well anything electrical can be serious, and lead to other problems and damage or fires..
 

Platinum Member
Username: Plymouth

Canada

Post Number: 13655
Registered: Jan-08
Shawn

You had not listed your car model, many car use a computer for all light in the car, try a reboot which is unplug the battery for 5 minutes and see if the problem still there!

Sometime a cable lose the shield because too much near and wears on body or motor!
 

Silver Member
Username: Skdooley

Roanoke, VA Usa

Post Number: 497
Registered: Oct-09
Thanks for all the responses. I'm going to take a look at it tomorrow and see if I can find out whats going on. I called my dad and he said it could be the fuse.
 

Platinum Member
Username: Plymouth

Canada

Post Number: 13656
Registered: Jan-08
Shawn

I will be very surprise if it was a fuse!

Which model?
 

Silver Member
Username: Finish22

Post Number: 110
Registered: Mar-10
if the turn signal flasher relay (on fuse box) needs to be replaced,
its gonna be bad ($$) news.
hope its just a bit loose from its socket....

BTW...before you check it, don't forget to disconnect the battery.
also check socket's condition (damaged, corroded,etc.)
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us