Like

Olds. 2004 Alero anyone???

 

Silver Member
Username: Tpizzle

Post Number: 208
Registered: Apr-05
alright my girlfriend has a new Alero and wants to deck the system out but i keep running into problems with it. Has any of you worked on a new alero system? first, all the stuff including the built-in amp is 8ohm so i know i need to take all the speakers, deck, and amp out, am i right. then i could replace the speakers and amp and deck. the problem im not sure about though is i took it to a nearby sound shop and they said with the new alero's, if the car doesn't have an "onstar" button, than a $100 piece of equipment has to be bought to put a new HU in. is this all correct? please help
 

Silver Member
Username: Tpizzle

Post Number: 220
Registered: Apr-05
does anyone drive one of these and have changed out any audio stuff. or does anyone know how to fix this problem?
 

Silver Member
Username: Tdeaton1021

Near Tampa, Florida USA

Post Number: 294
Registered: Sep-04
i cant realy help you... all i can say is a local shop charged me 90 dollars for harness for my escalade to get a ne HU and then later i found out they lied to me and i only needed a 13 dollar harness... so i took it back and the 13 dollar one works fine
 

Silver Member
Username: Tpizzle

Post Number: 221
Registered: Apr-05
walmart specials..gotta love em. harness- is that just the piece that holds the deck in place since the original is quite a bit larger?
 

Silver Member
Username: Tdeaton1021

Near Tampa, Florida USA

Post Number: 297
Registered: Sep-04
no the harness is what you plug the wires into.... its like when you unplug the wires form the stoick HU.... yyou need to get an aftermarket harness to plug the wires into and then just ocnnect the harnesses
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us