Like

Yet another Protection Light

 

Unregistered guest
I hate to Post another message like this but I have no other choice really. I just bought a dual amp and 2 dual 12" subs in a bandpass box from Best Buy(I don't really care how crappy anyone says they are, I just want a little more bass to my system and do not want to spend a lot of money) Anyways, I get everything hooked up and the protection light comes on whenever I power up my car. Everything is wired correctly, according to the diagrams and what not. The light will turn off if BOTH rca's are unplugged and that's it. It will stay on if the speakers are unplugged and I've tried unhooking everything except power and plugging the remote directly to the pos battery and the lights stays off until I plug in EITHER ONE of the rca's. I am at a loss. I am trying to avoid going to the store, so all help is appreciated
 

Unregistered guest
By the way, I tried a different pair of RCA cables and the red light still came on. Could this be the fuse on the power line by the battery? I've already replaced the fuse IN the amp itself. It can't be the speaker line if the light stays on after they are unplugged right?
 

solidius
Unregistered guest
just replaced the fuse holder/fuse all of that crap and still the same thing. someone please post anything that might help
 

Bronze Member
Username: Hdubb

Farmington, Nm Usa

Post Number: 94
Registered: Nov-04
check your ground wire. try taking the paint off where you are going to put the ground wire
 

Gold Member
Username: Glasswolf

NorthWest, Michigan USA

Post Number: 5968
Registered: Dec-03
if the ground is solid, and it's a true chassis ground which can be tested with continuity settings on a meter, then the amplifier may be bad.
 

Solidius
Unregistered guest
I have an old amp that I can try outon this wiring. But it's raining so hopefully it'll let up some so I can figure this out.Thanks guys.
 

Solidius
Unregistered guest
I just switched the ground AGAIN and everything is working now. I originally grounded it to the bolt that holds the back seat to the chassis but I guess that wasn't directly connected or something. And then later to another bolt for the seat belt. But that didn't work either. Who knows, it works now so it doesn't matter. Thanks for your help
« Previous Thread | Next Thread »

Facebook

Directory

Main Forums

Today's Posts

Forum Help

Follow Us