Like

Jonathan or Glasswolf or both??

 

Bronze Member
Username: Igotpenguinz

Mi

Post Number: 21
Registered: Oct-04
I still can't figure out what happened to my amp. Whenever I turn it on it makes this high intense constant noise. Did i blow it? I think it was when I was not thinking and messed with my amp when it was on. I was tightening a wire while it was on. (Don't be afraid to call me a dumbass.) If it is broken I geuss my audiobahn curse will be lifted.

What should I get if this is broken? I have 2 12 kicker L7s DVC 4ohm
 

Bronze Member
Username: Igotpenguinz

Mi

Post Number: 26
Registered: Oct-04
No one knows? Do i have a stumper?
 

Gold Member
Username: Glasswolf

NorthWest, Michigan USA

Post Number: 5300
Registered: Dec-03
check your wiring once more. remove one sub at a time to make sure one isn't blown, causing a short.
after that, I'd figure either the amp is damaged, or the head unit's RCA pre-out stage is damaged.
 

Bronze Member
Username: Igotpenguinz

Mi

Post Number: 27
Registered: Oct-04
What can I do to fix it? if it's the head units RCA?
 

Gold Member
Username: Glasswolf

NorthWest, Michigan USA

Post Number: 5316
Registered: Dec-03
send the unit in for repair
take it to a radio repair shop
replace it

those are the options
 

Bronze Member
Username: Igotpenguinz

Mi

Post Number: 28
Registered: Oct-04
you know a good repair shop in michigan? close to Clarkston?
 

Gold Member
Username: Glasswolf

NorthWest, Michigan USA

Post Number: 5322
Registered: Dec-03
Go to the manufacturer's website online and use their database for auth'ed repair centers based on location.
You should find one close to you.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us