Like

New HU plays radio but not CDs...? help please!

 

MrNeedsHelp
Unregistered guest
I recently bought a new sony HU to replace my dead pioneer. This is for a 95 Jeep GCherokee with infintiy gold speakers and a 500watt rockford fosgate and 2 10 MTX subs. Anyhow. After installing, the HU turns on fine, all the modes work EXCEPT, it wont play CDs. When I turn on the radio, i hear sound and it works fine. When I try CD mode, it will read the disc fine, change tracks, display the change in sound on the EQ bars... but 0 sound comes out. There isnt even static if i turn the volume to max. Dead, nothing.
If anyone knows of a specific setup that must be used for a sony HU and a jeep GC with infinity, please let me know! thanks
 

Silver Member
Username: Marley289

Post Number: 128
Registered: Nov-04
its sony, theres your problem. im just kidding, but check the wiring in the back, there may be something that isnt hooked up or its not hooked up right. did you install it or did you have it professionally installed. if a professional did it, take it back to them and tell them how it doesnt play the cds, they shouldnt charge you because they are the ones that made the mistake.
 

Silver Member
Username: Marley289

Post Number: 129
Registered: Nov-04
it could also be that you are trying to play cd-r and it doesnt play those. and if you are using cd-r's, it could be that you are burning them on the cd with the wrong format and that cd player cant read the format of the cd.
 

MrNeedsHelp
Unregistered guest
Fixed it. Turns out the way my speakers are set up the power is juiced to em when the antenna is also up.. i guess my old pioneer had the antenna and everything "active" whenever the HU was on. So now I hotwired the antenna to always be up.
thanks for the input
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us