Sigmatel MCNS Mp3 Player


New member
Username: Ccmc

Cleveland, Ohio United States

Post Number: 1
Registered: Dec-07
My new mp3 player does not displayed anything on it when I tried to install drivers on my laptop. I accidently clicked firmware upgrade and deleted everything. HELP?}

Platinum Member
Username: Project6

Post Number: 14760
Registered: Dec-03
Have you tried calling their tech support?

New member
Username: Graniti_office

Gjilan, Kosova Kosova

Post Number: 1
Registered: Mar-08
hi i have the problem as charles McPherson, i formated SigmaTel MSCN USB Device with SigmaTel MSCN Audio Player Firmware and now the lcd is off, does not displayed anything

can me help anyone...
write me in my email :

Platinum Member
Username: Project6

Post Number: 15405
Registered: Dec-03
Seems broken to me. Replace immediately.

New member
Username: Or2k

Lagos, Detla Nigeria

Post Number: 1
Registered: Jun-08
something is wroug with my ministry of sound mp3 player it keeps rebooting that is it will show it version and gos back to the beining (loop) version 2.521.102. please someone should tell me what to do

New member
Username: Olukayomide

Post Number: 1
Registered: Jan-10
My Mp3 Sigma Tel MSCN USB Device refuse to come up whenever i On it but if charging it come up show charging but if i remove the charger and try to ON it it fail to come up plz help me
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message


Shop Related Deals


Main Forums

Today's Posts

Forum Help

Follow Us