Philips Hdd060/17 1.5 GB


Unregistered guest
It worked okay for about two months and now when
I try to download my music, I get a message that
says "not accessible" I had a ! mark for a few minutes and now all I get is the icons that show I am transferring. But, guess what I'm not "transferring" anything. Anybody want to help. Thanks

I tried to post on another thread earlier, but the board was down.

I work on these and other HDD/Shoqbox units for Philips at one of their authorized repair facilities, so I have some first hand knowledge/experience/frustration with these. I may not tell you anything new, but this may help.

First of all, it sounds like your unit is toast. If you can't reset it, and it continues to go to the "!" screen, either the HDD or the main board has locked up. You can try to go to the Philips Web site and make sure you have the latest Device Manager and Firmware Upgrades for that unit, but if it doesn't see your unit or offer to repair it, it's dead. Call the Philips service line and get authorization to send it in. Probably not what you wanted to hear, but I've seen it quite a bit.


New member
Username: Quel_727

Saint Petersburg, Florida United States

Post Number: 1
Registered: Apr-06
well my mp3 player was working fine until one day it just froze and none of the buttons would work, please if anyone knows how to stop this from happening please let me know.

New member
Username: Mike_jonez

Margate, Fl Usa

Post Number: 1
Registered: Jun-06
This message keeps coming up everytime i plug my phillips HDD082/17. Error: One or more required files are missing. And i have tried everything, can anybody i mean anybody help me out, please

New member
Username: Emsley

Post Number: 2
Registered: Jul-06
« Previous Thread | Next Thread »


Shop Related Deals


Main Forums

Today's Posts

Forum Help

Follow Us