Like

Samsung DLP - Model HL56A650 problem

 

New member
Username: Capnjeff

Post Number: 1
Registered: Feb-11
Hello,
I have this 56" Samsung. While watching it, it began switching off. The blue led on the manual switch remained lit. No audio/no picture. Then it would switch back on. It seems to be either an overheating issue or possibly a capacitor issue that is very common on the Samsung LCD sets. Then it progressed switching off immediately after turning it on. After awhile, it will come on. There's no predicting how long it will stay on. I'm thinking dirty/malfunctioning fan or blown capacitor or??? Any suggestions would be appreciated.
 

New member
Username: Capnjeff

Post Number: 2
Registered: Feb-11
Okay, I've disassembled it this morning. No bulging capacitors. I tried to turn it on, it clicked, then turned off. Any suggestions?
 

New member
Username: Capnjeff

Post Number: 3
Registered: Feb-11
I carefully took out the motherboard and ballast. Cleaned them up, checked the connections and re-assembled it. It's been a day and a half with no issues. That's good, I know, but I wish I would have found a problem. Oh well...
 

Platinum Member
Username: Plymouth

Canada

Post Number: 15981
Registered: Jan-08
Welcome to eCoustics Jeff!

If the fan was dusted, the TV will fall in overheat protect mode!
 

New member
Username: Capnjeff

Post Number: 4
Registered: Feb-11
I'll go with that. The TV has worked flawlessly since I cleaned it up. Lucky me... Thanks, Plymouth. .
 

Bronze Member
Username: Zobeii77

Pakistan

Post Number: 16
Registered: May-11
Mark this post as Solved!!
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us