Hitachi C2514T dead after pincushion "repair"


New member
Username: Butterwince


Post Number: 1
Registered: May-06
This television had a slight hourglass pincushion distortion, but had been stable for several months. Both the adjustments on the pincushion correction circuit - VR751 gain (10K) & VR752 size (10K) - were turned to their maximum positions but this was insufficient to correct the problem.

On removal and inspection of the pincushion circuit board, an inductor (L783 - 560uH) showed signs of a dry joint and, when tested, had no connection to the board. The inductor itself showed a resistance of 500mOhms, so I assumed it was OK and proceeded to fix the dry joint.

When the set was powered-up the picture size was greatly reduced and the distortion had changed. I immediately associated this with VR751 and VR752 still being adjusted to maximum, but before I had the opportunity to change the positions the whole set powered down and is now dead.

Could the settings of VR751 and VR752 have caused something else to fail? Was something else faulty? What's faulty now?!

Unfortunately, it has turned from a known problem (pincushion) to an unknown.

Any insights/direction would be greatly appreciated.


(I have since removed the inductor and confirmed that it is OK. Fuses are also OK)

New member
Username: Butterwince


Post Number: 2
Registered: May-06
The problem was still on the east/west board: Diode D781 and transistor Q754 were both fried. Managed to get an exact replacement for the diode (BY228) but replaced the transistor (S2C1983) with TIP121. I have yet to increase the HT voltage to prescribed level.

Top Deals

Loading, please wait...
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message



Main Forums

Today's Posts

Top Deals

Forum Help

Follow Us