SONY AV SYSTEM RM-SS300 problems! Help please!

 

New member
Username: Mandyjayneuk

London

Post Number: 1
Registered: Sep-04
Wondering if anybody can advise or if I need to go to a Sony dealer and pay ££££££££££ to get this sorted.....

PLease bear with me, I know nothing of technology, and in despair at me still watching a 14" portable my brother kindly gave me the above system with a big telly as a gift.

This was 4 years ago, and it's lovely - does everything I need it to do, until recently, when it started freezing when I was playing DVDs, and sometimes CDs. My brother thinks it's having problems skipping between layers, whatever that might mean. I bought a lens cleaner, ont of those cds with brushes on the back, but it's made no difference.

Does anybody have any idea of what I might try next, and is it worth trying to get it repaired, or should I go for a new system?

Would be very grateful for any suggestions
 

Gold Member
Username: Project6

Post Number: 1444
Registered: Dec-03
Are the CDs and DVDs clean?
 

New member
Username: Mandyjayneuk

London

Post Number: 2
Registered: Sep-04
well d'uh! I just checked the manual and it's actually a DAV-S300. sorry about that. I was reading the info from the remote control..... ahem!
 

New member
Username: Mandyjayneuk

London

Post Number: 3
Registered: Sep-04
thanks for your reply, Berny. Yes, I make sure the discs are clean.

Maybe it's the world's first intelligent DVD player - it won't play Robbie Williams DVDs but loves Bad Girls!

It just seems to have a problem with music. I'm watching Moulin Rouge right now, and it's stopping, skipping, and just went back to the beginning of the film. Gah!
 

Gold Member
Username: Project6

Post Number: 1445
Registered: Dec-03
seems like the auto repeat function is on. Reset the player to original factory settings. Check the manual.
 

New member
Username: Mandyjayneuk

London

Post Number: 4
Registered: Sep-04
thank you, I'll try that. Your help is much appreciated.
 

Unregistered guest
my sony dvd player keeps sticking when i try to play movies on it. It then goes of and a blue screen appears saying 13.00. Can anyone help me.
 

Bhavik Kapadia
Unregistered guest
Look i need great advise!
when i put a dvd in the dvd player, most of the times it doesnt play and the sign appears on the screen as C-13 or NO DISC!
If anyone has a solution to this problem can you please write it on the forum!
Is it worth me repairing the dvd or buying a new one?
thank you
 

New member
Username: Ilver

Post Number: 1
Registered: May-05
I am having similar problems with my Sony to. I believe it is the new encryption they are using on the DVDs nowdays.

To be honest I think the Sony DAV-S300 was totally spoilt by the disc restrictions they have imposed on the system.

We bought a cheap £35 Pacific DVD player from Asda a few months back and run it through our Sony DAV-S300 on video 1 just to use the good sound from the speakers (you cant get surround sound like this). The cheap player plays anything that's put in it! And good quality picture to.

I heard there is a code that you can type in via the remote control for the Sony DAV-S300 to lift the restrictions of playing copied / encrypted discs. This may or may not be true and I have yet to find it if it's out there.

When I bought the DAV-S300 I wanted an excellent sounding DVD player with excellent picture and paid out £500 for it. The sound and picture are what I expected for my money but it was all sadly let down by this problem.

$ilver
 

New member
Username: Ilver

Post Number: 2
Registered: May-05
Two interesting links

http://www.multiregionupgrades.co.uk/upgrades/oldmods/725a.htm

http://www.videohelp.com/dvdhacks.php?select=Sony+DAV-S300

Remember if you try anything it's at your own risk :-)
 

New member
Username: Ilver

Post Number: 3
Registered: May-05
Also

http://www.videohelp.com/forum/viewtopic.php?t=217846&highlight=davs300

$ilver
 

Unregistered guest
Hi.....
i have a sony RM-SS300 dvd and i put the parental password long time ago and now i don't remember the numbers.... is there any way to reset that?? or reset the dvd it self?? please help me i can't see stars wars II.... can you belive it
atte: arturo reina
thanks
 

Kevin Ramsay
Unregistered guest
OK, this is going to sound really stupid but anyway. Just moved from UK to the Middle East, I've been trying to configure the DAV S-300 to play region 1 etc however it doesn't seem to accept the commands. Regardless of trying to press 1 then return it still won't play region 1 discs. By putting it on "standby" I'm assuming they mean switched on with no disc loaded.
Any pointers please
Jump to: Home Audio Forum | Home Video Forum | Home Theater Forum | Car Audio Forum