Like

My NAD T743 has a problem

 

New member
Username: Spieker

Post Number: 1
Registered: May-11
Hello,

My NAD T743 has a problem, when i turn it on, then after a couple of minutes the display shuts down, and i cant change the channels or change the volume anymore. i have to shut the power off on the back of the amp and wait 10 minutes before i can change anything. but when the display shuts down the sound stay's perfect! but i cant do anything anymore whit it. i hope someone can help me whit this problem.
 

Platinum Member
Username: Plymouth

Canada

Post Number: 16224
Registered: Jan-08
Welcome to eCoustics spieker!

I founded this answer about your problem!

Just had my t753 in bits... sounds like its overheating to me. Check that the fans on the bottom still turn and aren't clogged up with dust. Make sure that it has plenty of ventilation.

hmm, also try unplugging everything and leaving it on and see if it still freezes? ie check you're cabling is ok, there are no shorts from bare speaker wires etc...

Could try resetting it too? (in each case hold the buttons for 5 seconds then release)
- Firmware version: hold video 6 and tone control
- Reset DSP: video6 + tone defeat
- Reset completely: video6 + right source button (this will wipe all settings - hold for 5 seconds, release and then unplug from the wall or turn off with the rear power switch)


Good luck!
 

Platinum Member
Username: Plymouth

Canada

Post Number: 16505
Registered: Jan-08
ZZZ
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us