Like

RM6750 Clicking Sound

 

New member
Username: Gatorrob86

Post Number: 2
Registered: Feb-08
Connected RM6750 yesterday to Pioneer VSX-1020-K receiver. Watched some sports, and action scenes from various DVDs. Speakers sound great. Watched Crossing Delancey and noticed a clicking from the front left speaker at two spots in the movie (approx. 4 brief clicks during dialog that was audible). The movie was recorded on my Tivo from an over-the-air broadcast from local PBS station. The movie is from 1988 and there was no audio from rear speakers (I am assuming it was pre-surround sound). I was able to rewind to a specific spot in the movie and reproduce the clicking every time. This suggests to me it is a problem with the soundtrack or the broadcast (there was no video distortion during the clicking to suggest a weak broadcast signal).

But because the clicking was coming from only the front left speaker, I want to rule out a bad speaker. Any thoughts would be greatly appreciated.
 

Platinum Member
Username: Plymouth

Canada

Post Number: 16160
Registered: Jan-08
Hi Bob!

Certainly it coming from the sountrack but you can try to switch the left and right speaker to see if it coming from your speaker!
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us