Like

Sunfire True Subwoofer MKII sparking

 

New member
Username: Course_rider

Carver, MN USA

Post Number: 1
Registered: May-14
I'm fixing a Sunfire True Subwoofer MKII amp that blew all 3 fuses. I replaced all the transistors that are mounted to the plate.
6- IRF640
2- 2SC3281
2- 2SA1302
1- A1837
1- C4793

I checked the rest of the smaller TO-92 transistors and they seem OK, not shorted.

As I plugged the amp in there was a big arc flash at the plug,and I unplugged it right away. I checked the transistors and they seem OK (not shorted). The power cap connected to the power entry measures 140v. The other large cap measures 80v. The speaker terminals measure 17v with a volt meter (no speaker plugged in).
I have fixed a few sub amps in my day, but nothing like this. Why would there be 17v output at the speaker terminals?
Is the arcing just a power surge to charge the capacitors?
I'm not sure if I should check the rectifier with voltage across it.

Any recommendations.
 

Gold Member
Username: Magfan

USA

Post Number: 3121
Registered: Oct-07
Sounds like you took the bridge rectifier out, too.

Can you check it power off and unplugged after sitting for an hour? 'Zap' the PS caps with a resistor before proceeding, in any event.

Good Luck getting schematics from Carver.
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us