Philips GoGear 4gb


New member
Username: K_rae23

Post Number: 1
Registered: Dec-09
I recently purchased a Philips GoGear 4gb Mp3 player. I correctly installed the software and everything, but when I connect the player to my computer, it doesn't recognize it. I've tried using Windows Media Player and it shows no device connected. Any advice would be greatly appreciated!

New member
Username: Manidhar

Post Number: 1
Registered: Mar-10
I got a Philips Go Gear 4GB Ipod which I bought in 2007. I works wonderful. But, today, I connected that to my desktop computer to organize the playlists at 11 a.m. and it was continuously kept connected till 3:15 pm. During this time, there were 3 times, my computer went auto log off and on. Suddenly, at 3:15 p.m., I got prompted on the computer screen that the ipod is not respond or switched off. When I checked the ipod, it went switched off on its own and since then its not getting on even though I tried so much to switch it on...........Please kindly suggest me the solution..............I love my ipod a lot and it is the only friend of mine who relieves my day long stress and strain.............Please please please kindly help me.........

Gold Member
Username: Jrbay

Livonia [Detroit area], Michigan USA

Post Number: 1163
Registered: Feb-08
Try removing and restoring (R & R) the battery. If it is a software lockup then that should reset it. The other consideration would be a dead battery but hopefully you have thought of that already!

Top Deals

Loading, please wait...
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message



Main Forums

Today's Posts

Top Deals

Forum Help

Follow Us