Pioneer deq-7600 4 wire hook up. Cant get it to power up.


New member
Username: Cmann

Post Number: 1
Registered: Jun-04
I need the power hook up dia gram for a pioneer deq-7600 equalizer. i cant seem to get it to power up. I am using the same power as the head unit. The EQ has only four wires:battery , illumination, remote on, i missing something here? have done all basic trouble shooting...maybe something to do with the Alpine head unit?....not sure.

Silver Member
Username: Project6

Post Number: 875
Registered: Dec-03
is the blue wire connected to the other blue wire of the alpine head unit?

ryan "macgiver" swanson
Unregistered guest
any one or any thing help me i cant find a wiering guied to my pioneer graphics eqalizer molel number BP-450 and im basicaly car stereo illiterat please help e-mail me if you can this is urgent need it ASAP!!!

New member
Username: Motoxrider70

Johnsburg, Illinois United States

Post Number: 1
Registered: Sep-05
Hi, I have a big delimma. I have a pioneer Headunit, Two 10" Royal Red Subwoofers, a 1500 wat Boss Audio amp, and 2 stock nissan 300ZX speakers. While attempting to hook up 2 new pioneer 6"9" speakers, i hooked it all up, and when i would go to turn up the volume the screen on my headunit would flicker and reset my headunit. When I tried to fix this problem, i must of disconnected a wire, and now my whole headunit does not power up. Please someone let me know what Im doing wrong?

Gold Member
Username: Project6

Post Number: 3732
Registered: Dec-03
Your dilemma will be eased by posting in the proper forum. This is the HOME AUDIO forum. Try the CAR AUDIO forum.


Top Deals

Loading, please wait...
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message



Main Forums

Today's Posts

Top Deals

Forum Help

Follow Us