Quad 99 stereo power amp HELP

 

New member
Username: Pugster

STOKE ON TRENTENGLAND

Post Number: 1
Registered: Sep-05
My Quad 99 stereo power amp keeps cracking and popping. This fault was diagnosed 12mths ago and sent to be serviced. It took 4 mths to get it back and now it's doing the same thing again. Quad said there was no fault found and charged me £60+.

PLEASE PLEASE HELP ME AS I HAVE NO BACKUP AMP
 

Gold Member
Username: Jan_b_vigne

Dallas, TX

Post Number: 5478
Registered: May-04


Contact Quad and tell them your situation. Possibly the problem will have become easier to trace at this point. Your description of the problem is too vague to give any more advice than that.



 

New member
Username: Pugster

STOKE ON TRENTENGLAND

Post Number: 2
Registered: Sep-05
The crackling is random and on both l and r simultaneously
The volume is constant at low or high outputs

ps Quad are useless the test they did took 1 month then 3 months of waiting until I contacted them to ask what was happening!!
 

Gold Member
Username: Jan_b_vigne

Dallas, TX

Post Number: 5481
Registered: May-04


Well, Quad or one of the authorized service centers are the folks who will have to repair this; aren't they? There's no way to track this problem on a forum if Quad couldn't do it in a month.



 

New member
Username: Pugster

STOKE ON TRENTENGLAND

Post Number: 3
Registered: Sep-05
Thanks Jan, i'll try to find a local service centre as the amp is out of guarantee and it costs £30+ on del.
 

Silver Member
Username: Frank_abela

Berkshire UK

Post Number: 857
Registered: Sep-04
Hmmm, sounds to me like the output capacitors are shot. Shouldn't happen to something that young.

Frank.
 

New member
Username: Pugster

STOKE ON TRENTENGLAND

Post Number: 4
Registered: Sep-05
Thanks Frank, i'll get on to it.
 

Gold Member
Username: Jan_b_vigne

Dallas, TX

Post Number: 5518
Registered: May-04


Output caps? Isn't the 99 a direct coupled design?
 

Unregistered guest
Hi David!

Iv just started having the same problem as you.
Do you get the poping even when you are playing music? My quad pops even when I switch it off.

Im not too sure if its my CD, pre amp or power amp?
 

New member
Username: Pugster

STOKE ON TRENTENGLAND

Post Number: 5
Registered: Sep-05
Danny

Mine pops and crackles constantly at the same volume, with or without an audio signal. I've isolated the power amp as the culprit.
Jump to: Home Audio Forum | Home Video Forum | Home Theater Forum | Car Audio Forum