Like

Old Sony, (MHC-C70)

 

Sarah H
Unregistered guest
Everything works fine on this system except my CD player doesn't recognize when there is a CD inside. Once in a long while it will realize there's one in there and play it fine.

Possible cause: on the bottom of the system there are three screws that are supposed to be put in when moving the system which my sister neglected to do when she borrowed it.

Does this sound like something easy to fix? Any ideas?
 

Silver Member
Username: Edison

Glendale, CA US

Post Number: 641
Registered: Dec-03
That could be the problem - You might want to clean the lense if it can be located easily. Other than that, you need servicing, or might be better to get a different one. There are better sounding ones like onkyo mini on ebay for a little over $200.
 

Unregistered guest
I have a MHC-C70 too, and have same problem. Unit is over 10 years old. I took it apart to see if I could easily get at the lense, but it really looks like it is in the middle of the tray/changer mechanism. Guessing that buying a new system is going to be cheaper than service.
 

Unregistered guest
Will purchase your mhc c70 flat cord connection.
 

New member
Username: Madmaggie

Post Number: 1
Registered: Sep-06
I have a 1993 version of the sony mhc c70 and the radio station display is dark. It plays fine but no station numbers displayed. Any ideas? TX
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us